mysql show too many connections ( via a telnet test or in the logs )

Description

Error message  "too many connections" shows up:

------------------------------------------------------------------

  • the connection to the mysql database , for example a Console-GMS Installation with the integrated mysql db show this error
  • a telnet test to the consoleIP via "telnet consolegms-ip 3306" shows "too many connection"
  • other example : Log-Message of the Agent which tries to connect to the Console-GMS shows "too many connection" 

 

simple test via telnet and port 3306 to the GMS-IP which has the MySQL-DB:

Error message: "Too many connections"

Image

- for example "telnet 123.123.123.123 3306" ( 123.123.123.123 can be a standalone or a console-Role or a DB-Role )

Cause

- there are too many requests coming in or some mysql-database connection are freezing and the number of connection increase

- one cause could be a high number of Agents, trying to connect to the Console-GMS IP ( which includes the mysql - db )

Resolution

- Solution:

* Find out where the MySQL DB is located ( typically the GMS-Console or a dedicated GMS-DB-Role ) . Access this GMS System

* Increase the Number of maximum allowed connection to the mysql-database  in the techSupport.html site  from 365 to 500 of this GMS

* Reboot the Windows-Server ( in a GMS software environement ). If it is a VA on a ESX(i) Server reboot the GMS VA

 

Follow this steps to reach the internal techSupport.html page:

---------------------------------------------------------------------

1) Login to the https:// your gms ip /sgms/login page

2) Change the url to https://youtgmsip/sgms/techSupport.html in the URL-Browser ( change it manually )

Image

3) Click enter and you reach this site and then click on Accept

Image

 

 

********************************************************************************************************

4) Now change the max connection value from 365 to a higher value ( like for example 500 )

********************************************************************************************************

 

Image

5) Click update

6) Reboot the GMS ( either via the command line or you can restart the windows server or you can restart via the system interface )

 

Related Articles

  • How to disable Geo-IP feature of "Block all UNKNOWN countries" to a group of firewalls using GMS 9.3
    Read More
  • Disabling Block all UNKNOWN countries in firewall group in NSM
    Read More
  • Forward syslog to another server with On-Prem Syslog Analytics
    Read More
not finding your answers?
was this article helpful?