Imported Certificates Not Validating

Description

Certificate installed on the UTM but it states validated No.

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Cause

The intermediate or root certificate from the certificate chain are different than those on the UTM or are missing from those on the UTM.

Resolution

*Warning this process will require a restart of the UTM to complete the process*

If the CSR was created from the UTM, Then: Install Certificate Chain:

Obtain the .cer or .crt file that was sent from the Certificate Provider.

Double-Click the file.

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Go to Certification Path Tab. Highlight the Intermediate. Click View Certificate.

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The Intermediate Certificate will pop-up.

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Go to the Details Tab. Click Copy to File.

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The Certificate Export Wizard will pop-up. Click Next.

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Select .p7b and check Include all certificates in the certification path. Click Next.

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Click Browse

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Set the path you want the file saved to and save the file as ANYNAME.p7b. Click Save.

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Click Next.

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Click Finish.

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There will be a pop-up stating The export was successful. Click OK.

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Import the p7b you have created into the UTM. In order to do this log into your UTM. Go to System > Certificates. Click Import.

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Select Import a CA certificate from a PKCS#7 (.p7b). Click Choose File.

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Select the .p7b created earlier and click Open.

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Click Import.

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The certificate should now state Validated Yes.

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Restart the UTM and verify the certificate stays validated.

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