Troubleshooting scenarios where the SonicWall DHCP pool runs out of addresses

Description

This article explains how to troubleshoot situations where the SonicWall logs mention "DHCP Resources of this pool ran out"

Cause

This is usually caused by

  • Too many devices in the network, i.e the DHCP pool is actually exhausted.
  • IP addresses are not getting recycled from devices that have left the network.

Resolution

Resolution for SonicOS 7.X

This release includes significant user interface changes and many new features that are different from the SonicOS 6.5 and earlier firmware. The below resolution is for customers using SonicOS 7.X firmware.

  • For the first situation mentioned above, the DHCP scope has to be increased to accommodate the new devices.
  • For the second situation, changes can be made on the SonicWall by:
    • Navigating to Network | System | DHCP Server | DHCP Server Lease Scopes. 
    • Edit (Image) the existing DHCP scope and change the Lease Time option to a lower value (The default is 1440 minutes)
    • Image
    • Navigate to Network | System | DHCP Server | DHCP Server Settings. Click on Advanced. Check the "Aggressively recycle expired DHCP leases in advance" option. This will ensure unused addresses are freed.
    • Image
    • Image
    • Navigate to diag page of the firewall and search for DHCP settings. Change the values for Time interval of DHCP lease database to be refreshed and Number of DHCP leases in database to be refreshed. The former recycles the lease database more frequently and the latter recycles more leases at a time.
    • Image

Resolution for SonicOS 6.5

This release includes significant user interface changes and many new features that are different from the SonicOS 6.2 and earlier firmware. The below resolution is for customers using SonicOS 6.5 firmware.

  • For the first situation mentioned above, the DHCP scope has to be increased to accommodate the new devices.
  • For the second situation, changes can be made on the SonicWall by:
    • Navigating to Manage | Network | DHCP Server. Edit (Image) the existing DHCP scope and change the Lease Time option to a lower value (The default is 1440 minutes)
      Image
  • Navigate to the diag.html page of the firewall. Check the "Aggressively recycle expired DHCP leases in advance" option. This will ensure unused addresses are freed.
  • Change the values for Time interval of DHCP lease database to be refreshed and Number of DHCP leases in database to be refreshed. The former recycles the lease database more frequently and the latter recycles more leases at a time.
    Image

Related Articles

  • SonicOS 8.1.0 FAQ
    Read More
  • SonicWall GEN8 TZs and GEN8 NSas Settings Migration
    Read More
  • Getting started with SonicWall firewalls
    Read More
not finding your answers?