How to configure Local CFS Server
03/26/2020 800 People found this article helpful 474,583 Views
Description
This guide shows the steps to configure the Local (on-premises) CFS Server.
The CFS Local Responder Service is a Virtual Machine (VM) running CFS Services and it can be installled locally on a network. The firewall will point to this VM for ratings lookup.
It will also include Proxy Support with authentication.
NOTE: This service will require an additional license to be installed and configured.
Cause
The Local CFS Responder Service is a new feature developed to extend and enhance CFS service availability. In depth, it improves CFS performances in some cases:
- Networks behind proxies, because it uses UDP for ratings.
- Schools, high performance environments need dedicated on-premises appliances.
- CFS rating queries from some countries will take a considerable amount of time.
Resolution
Configure the Local CFS Server
- Install the Local CFS Responder Service onto a local machine/VM: it can be downloaded from you download center on MySonicWall.com
NOTE: Please, make sure to follow the suggested VM Specs: ESX/ESXi / Hyper-V, 50GB Hard Disk; Quad-Core CPU; 16GB RAM.
- Configure an IP Address for the Local CFS Server (including subnet mask, gateway and DNS).
- If using a Proxy Server, you will have to enable "Connecting to backend Server with proxy" and type the Proxy Server details:
Configure the SonicWall to contact the Local CFS Server for rating requests
- Go to the Manage tab
- Click Security Services | Content Filtering
- Check "Enable Local CFS Server"
- Type the Local CFS Server IP address
CAUTION: This section will only be displayed if there is a valid license for the Local CFS Server.
Configuring Blacklist or Whitelist
You can now import a blacklist or add blacklisted URLs one by one by clicking the Blacklist/Whitelist tab:
Local CFS Server Administration
From the Administration tab you can manage your Local CFS Server:
- Change the password
- Apply firmware upgrade
- Restart the appliance
- Import/Export Settings
NOTE: The message "There is no rating update from Cloud DB" indicate that the Cloud DB is still the same as the one previously downloaded and locally stored. The local CFS Server will attempt to download the database every hour but if there is no update, it will not be downloaded.
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