Como posso resolver o drop "Cache Add Cleanup"?
03/21/2024 0 People found this article helpful 100,733 Views
Description
Este artigo fornece etapas de solução de problemas para resolver pacotes descartados no firewall SonicWall devido ao drop code "Cache Add Cleanup".
Cause
O Drop Code "Cache Add Cleanup" pode ser legítimo, pois o firewall eliminará tudo o que vier fora de ordem.
NOTA: Se um pacote ACK de uma conversa TCP chegar após a conexão ter sido encerrada por um pacote ACK/FIN ou RST, o pacote ACK será descartado como "Cache Add Cleanup": esta mensagem de erro informa que o firewall não tem conexões ativas em relação ao pacote recebido, então o pacote não pode ser aceito.
Resolution
Resolução para SonicOS 7.X
Esta versão inclui alterações significativas na interface do usuário e muitos recursos novos que são diferentes do SonicOS 6.5 e do firmware anterior. A resolução abaixo é para clientes que usam firmware SonicOS 7.X.
Você pode querer verificar o seguinte:
- Revisar a conversa TCP usando o Packet Monitor. Se o pacote descartado for recebido após o fechamento da conexão (pacote FIN ou RST), o descarte é legítimo. Nesse caso, você precisará descobrir por que a conexão foi fechada/reiniciada antes do final dela, verificando a máquina que está enviando o pacote FIN/RST.
- Tentar desabilitar Enforce strict TCP compliance with RFC 793 and RFC 1122 em Network | Firewall | Flood Protection.
ATENÇÃO: Isso reduzirá a segurança da sua rede. - Certifique-se de que o Tempo Limite de Conexão TCP (TCP Connection Timeout) esteja na access rule específica ou em Network | Firewall | Flood Protection não seja muito baixa (por padrão, é definida como 15 minutos).
- Tente desabilitar "Enable TCP sequence number randomization" na página do diag do firewall (https://IP of the SonicWall/sonicui/7/m/mgmt/settings/diag).
- Se o tráfego descartado for VPN, certifique-se de ter um IP público definido na interface WAN: uma condição de NAT duplo pode fazer com que o firewall descarte o tráfego como "Cache Add Cleanup" devido à alteração no cabeçalho do pacote.
Resolução para SonicOS 6.5
Esta versão inclui alterações significativas na interface do usuário e muitos recursos novos que são diferentes do SonicOS 6.2 e do firmware anterior. A resolução abaixo é para clientes que usam firmware SonicOS 6.5.
Você pode querer verificar o seguinte:
- Revisar a conversa TCP usando o Packet Monitor. Se o pacote descartado for recebido após o fechamento da conexão (pacote FIN ou RST), o descarte é legítimo. Nesse caso, você precisará descobrir por que a conexão foi fechada/reiniciada antes do final dela, verificando a máquina que está enviando o pacote FIN/RST.
- Tentar desabilitar Enforce strict TCP compliance with RFC 793 and RFC 1122 em Firewall Settings | Flood Protection.
ATENÇÃO: Isso reduzirá a segurança da sua rede. - Certifique-se de que o Tempo Limite de Conexão TCP (TCP Connection Timeout) esteja na access rule específica ou em Manage | Firewall Settings | Flood Protection não seja muito baixa (por padrão, é definida como 15 minutos).
- Tente desabilitar "Enable TCP sequence number randomization" na página do diag do firewall (https://IP of the SonicWall/diag.html).
- Se o tráfego descartado for VPN, certifique-se de ter um IP público definido na interface WAN: uma condição de NAT duplo pode fazer com que o firewall descarte o tráfego como "Cache Add Cleanup" devido à alteração no cabeçalho do pacote.
NOTA: Os números do drop codes podem mudar com base na versão do firmware, no entanto, a mensagem do código de entrega (descrição) permanece a mesma.
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