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NetExtender Feature Overview
Topics:

l Document Scope

Document Scope
This document provides a brief overview of the SonicWall SMA 10.2.1 NetExtender features, concepts, and how
to configure and manage them.

Topics:

l What is NetExtender
l Benefits of using NetExtender
l NetExtender Concepts
l Supported Platforms
l Feature Support in NetExtender

What is NetExtender
SonicWall NetExtender is a transparent software application that enables the remote users to securely connect to
the remote network. With NetExtender, remote users can securely run any application on the remote network.
Users can upload and download files, mount network drives, and access resources in the same way as if they
were on the local network. The NetExtender connection uses a Point-to-Point Protocol (PPP) connection.

Benefits of using NetExtender
NetExtender provides remote users with full access to the protected internal network. The experience is virtually
identical to that of using a traditional IPSec VPN clients, but NetExtender does not require any manual client
installation. Instead, the stand-alone NetExtender client is automatically installed on the PC of a remote user by
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an HTML5 control when using the Edge or Firefox. On Linux systems, supported browsers use Java controls to
automatically install NetExtender from the Virtual Office portal.

The NetExtender Windows client also has a custom-dialer that allows it to be launched from the Windows
Network Connections menu. This custom-dialer allows NetExtender to be connected before the Windows domain
login. The NetExtender Windows client also supports a single active connection, and displays real-time
throughput and data compression ratios in the client.

After installation, NetExtender automatically launches and connects a virtual adapter for SSL-secure
NetExtender point-to-point access to permitted hosts and subnets on the internal network.

NetExtender Concepts
The following sections describes the advanced concepts of SonicWall NetExtender

l Stand-Alone Client

l Installing NetExtender through Microsoft Installer - Pre-filling the Server and Domain Fields

l NetExtender support Network logon (PreLogon)

l Multiple Ranges and Routes

l IP Address User Segmentation

l Client Routes

l External Authentication Methods

l Point to Point Server IP Address

l Tunnel All Mode

l Proxy Configuration

l About SMA Connect Agent

l Supported Operating Systems for Connect Agent

Stand-Alone Client
Secure Mobile Access provides a stand-alone NetExtender application. NetExtender is a browser-installed
lightweight application that provides comprehensive remote access without requiring users to manually download
and install the application. The first time a user launches NetExtender, the NetExtender stand-alone client is
automatically installed on the user’s PC. The installer creates a profile based on the user’s login information. The
installer window then closes and automatically launches NetExtender. If the user has a legacy version of
NetExtender installed, the installer first uninstalls the old NetExtender and installs the new version.

After the NetExtender stand-alone client has been installed, Windows users can launch NetExtender from their
PC’s Start > Programsmenu and configure NetExtender to launch whenWindows boots.

NetExtender can establish a VPN session before the user logs into the Windows domain. Users can click Switch
User on the Windows login screen and click the blue computer icon that appears at the right bottom of the screen
to view the dialup connection list, and then can select NetExtender to connect.
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On Linux systems, the installer creates a desktop shortcut in /usr/share/NetExtender. This can be dragged to
the shortcut bar in environments like Gnome and KDE.

NetExtender is officially supported on the following client platforms

l Fedora core 36+ or Red Hat Enterprise Linux 8.x+

l Ubuntu 20.04+

l OpenSUSE 15.4+ or CentOS 8.x+

l Windows 11/10

NetExtender might work properly on other Linux distributions, but they are not officially supported by SonicWall.

Installing NetExtender through Microsoft Installer - Pre-filling
the Server and Domain Fields
Installing NetExtender through Microsoft Installer (MSI) now supports the use of default profile settings during the
installation process where the default server and default domain can be pre-filled along with additional options
that control whether the server and domain fields can be edited by a standard user. This feature is designed
specifically for administrators who want their default servers and domains pre-set during the installation process.

To set the default server and domain during the NetExtender Installation with Microsoft Installer:

1. On the Default Profile Setting page, enter the IP address of the Default Server in the appropriate
fieldand the location of the Default Domain in the second field.

2. Disable Allow connections to other profiles to prevent users from connecting to other profiles. This
setting disables the Server and Domain fields for editing on the login page of NetExtender.

3. Enable this option to allow those connections. If this option is not enabled, users are not able to add or
delete profiles on the NetExtender properties page.

NetExtender support Network logon (PreLogon)
NOTE: Network Logon support is available from SMA 10.2.1.9 onwards.

Users always log in to their Windows accounts before connecting a VPN tunnel. But in a typical scenario, a VPN
tunnel (NetExtender) is required to allow the user to log in for the first time or after a password reset. Network
Logon (PreLogon) is a feature that allows users to establish a VPN tunnel (NetExtender) before they can log on to
their Windows accounts.

To enable Network Logon (PreLogon) and more information, see Enabling Network Logon (PreLogon) feature on
NetExtender section.

Multiple Ranges and Routes
The Network administrators can use the multiple range and route support of NetExtender to easily segment
groups and users, without configuring firewall rules to govern access. This user segmentation allows granular
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control of access to the network, allows users to access the necessary resources, and restricts access to the
sensitive resources to only those who require them.

For networks that do not require segmentation, client addresses and routes can be configured globally.

IP Address User Segmentation
Administrators can configure separate NetExtender IP address ranges for users and groups. These settings are
configured on the Users > Local users and Users > Local groups pages. A NetExtender tab has been added
to the Edit User and Edit Group windows.

When configuring multiple user and group NetExtender IP address ranges, it is important to know how the SMA
appliance assigns IP addresses. When assigning an IP address to a NetExtender client, the SMA appliance uses
the following hierarchy of ranges:

l An IP address from the range defined in the user’s local profile.

l An IP addRess from the range defined in the group profile to which the user belongs.

l An IP address from the global NetExtender range.

To reserve a single IP address for an individual user, enter the same IP address in both the Client Address
Range Begin and Client Address Range End fields on the NetExtender tab of the Edit Group window.

Client Routes
NetExtender client routes are used to allow and deny access to various network resources. You can configure the
client routes at the user and group level. NetExtender client routes are also configured on the Edit User and Edit
Group windows. The segmentation of client routes is fully customizable allowing administrator to specify any
possible permutations of user, group, and global routes. For example, only group routes, only user routes, group
and global routes, user, group, and global routes, and so on. This segmentation is controlled by Add Global
NetExtender Client routes and Add Group NetExtender Client routes.

External Authentication Methods
Networks that use an external authentication server are not configured with local user names on the SMA
appliance. In such cases, when a user is successfully authenticated, a local user account is created when the
Add Global NetExtender Client routes and Add Group NetExtender Client routes settings are enabled.

Point to Point Server IP Address
In Secure Mobile Access, the PPP server IP address is 192.0.2.1 for all connecting clients. This IP address is
transparent to both the remote users connecting to the internal network and to the internal network hosts
communicating with remote NetExtender clients. Because the PPP server IP address is independent from the
NetExtender address pool, all IP addresses in the global NetExtender address pool are used for NetExtender
clients.
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Tunnel All Mode
Tunnel All mode routes all traffic to and from the remote user over the Secure Mobile Access NetExtender tunnel
including traffic to the remote users local network. This accomplished by adding the following routes to all remote
clients’ route table.

IP Address Subnet Mask

0.0.0.0 0.0.0.0

0.0.0.0 128.0.0.0

128.0.0.0 128.0.0.0

TUNNEL ALL MODE: ROUTES TO BE ADDED TO REMOTE CLIENT’S ROUTE TABLE

NetExtender also adds routes for the local networks of all connected Network Connections. These routes are
configured with higher metrics than any existing routes to force traffic destined for the local network over the
Secure Mobile Access tunnel instead. For example, if a remote user is has the IP address 10.0.67.64 on the
10.0.*.* network, the route 10.0.0.0/255.255.0.0 is added to route traffic through the Secure Mobile Access
tunnel.

Tunnel All mode is configured at the global, group, and user levels.

Proxy Configuration
SMA appliances support NetExtender sessions using proxy configurations. Currently, only HTTPS proxy is
supported. When launching NetExtender from the Web portal, if your browser is already configured for proxy
access, NetExtender automatically inherits the proxy settings. The proxy settings can also be manually
configured in the NetExtender client preferences. NetExtender can automatically detect proxy settings for proxy
servers that support the Web Proxy Auto Discovery (WPAD) Protocol.

NetExtender provides three options for configuring proxy settings:

l Automatically detect settings - To use this setting, the proxy server must support Web Proxy Auto
Discovery Protocol (WPAD) that can push the proxy settings script to the client automatically.

l Use automatic configuration script - If you know the location of the proxy settings script, you can select
this option and provide the URL of the script.

l Use proxy server - You can use this option to specify the IP address and port of the proxy server.
Optionally, you can enter an IP address or domain in the BypassProxy field to allow direct connections to
those addresses and bypass the proxy server. If required, you can enter a user name and password for
the proxy server. If the proxy server requires a username and password, but you do not specify them, a
NetExtender pop-up window prompts you to enter them when you first connect.

When NetExtender connects using proxy settings, it establishes an HTTPS connection to the proxy server
instead of connecting to the SMA server directly. The proxy server then forwards traffic to the SMA server. All
traffic is encrypted by SSL with the certificate negotiated by NetExtender, of which the proxy server has no
knowledge. The connecting process is identical for proxy and non-proxy users.
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About SMA Connect Agent
The Browser Plug-ins (NPAPI) are used to launch native applications such as NetExtender, EPC and so on. For
security reasons, popular browsers block theses Plug-ins. The Chrome and Edge browsers, for example, has
disabled all NPAPI Plug-ins. As such, the ease-of-use ability of launching directly from the browser is no longer
functional, and a new method for seamless launching is necessary.

There is another application to launch that opens a specific Scheme URL. There are some Schemes already
defined in the Windows/macOS, such asmailto. The SMA Connect Agent uses the Scheme URL to replace the
Browser Plug-ins. The SMA Connect Agent is like a bridge that receives the Scheme URL requests and launches
the specific native application.

To launch the Citrix Workspace through a Citrix bookmark, you must first install the SMA Connect Agent.

Supported Operating Systems for Connect Agent
The SMA Connect Agent supports Windows and Mac operating systems.

Supported Platforms
Topics:

l NetExtender Client Versions
l Supported Clients
l Supported SonicWall Appliances

NetExtender Client Versions
The NetExtender client versions include the following:

Description Version

NetExtender for Windows 10/11 64 bit MSI/EXE 10.2.337

NetExtender for Windows 10 32-bit MSI/EXE 10.2.337

NetExtender for 32-bit Linux TGZ 10.2.850

NetExtender for 64-bit Linux TGZ 10.2.850

NetExtender for 32-bit Linux RPM 10.2.850

NetExtender for 64-bit Linux RPM 10.2.850

Supported Clients
NetExtender 10.2.337 is supported on computers running the following Windows versions:
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l Windows 11/10 with the latest patches.

NetExtender 10.2.850 is supported on computers running the following Linux versions:

l Ubuntu 20.04+.

l Fedora Core 36+ or Red Hat Enterprise Linux 8.x+.

l OpenSUSE 15.4+ or CentOS 8.x+.

NOTE: Always on VPN and SND are available with NetExtender MSI client for Windows, but not with
NetExtender for Linux.

Supported SonicWall Appliances
SonicWall appliances receive NetExtender connections from remote clients. The following appliances are
supported:

SonicWall firewalls runningSonicOS 7.0, including the following platforms:

l TZ670, TZ570, TZ570W, TZ570P running SonicOS 7.0

l NSv 270, NSv 470, and NSv 870 running SonicOS 7.0

l NSsp 15700 running SonicOS 7.0

SonicWall firewalls running SonicOS 6.5, including the NSa, TZ, SOHO, and SuperMassive series platforms:

l NSa 2600-6600

l NSa 2650-9650

l TZ300-TZ600, TZ300W-TZ500W, TZ300P, TZ600P, TZ350, TZ350W

l SOHOW, SOHO 250, SOHO 250W

l SuperMassive 9200-9600

Secure Mobile Access (SMA) 100 Series appliances running 9.0 or higher:

l SMA 200/400

l SMA 210/410

l SMA 500v for ESXi (on ESXi 6.0 and higher)

l SMA 500v for Hyper-V (on Hyper-V 2016 and 2019)

l SMA 500v for AWS

l SMA 500v for Azure

l SMA 500v for KVM
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Feature Support in NetExtender

Feature
Supported by NetExtender for
Windows Supported by NetExtender for Linux

Tunneling Yes Yes

Certificate Authentication Yes No

SAML Authentication Yes Yes

TLSv1.3 Support No Yes

Always On VPN Yes No

Endpoint Control Yes Yes

Personal Device
Authorization

Yes Yes

Auto Reconnect Yes Yes

Credential Cache Yes Yes

Post Connection Script Yes Yes

Network Logon (PreLogon) Yes No

FEATURE SUPPORT ON NETEXTENDER FOR WINDOWS AND NETEXTENDER FOR LINUX

Feature Supported on SMA 100 Supported on Firewalls

Always On VPN Yes No

SAML Authentication Yes Yes

One-Time Password Method
Switching

Yes Yes

Post Connection Script Yes No

Endpoint Control Yes No

Personal Device Authorization Yes No

DHCP IP Pool Yes Yes

Network Logon (PreLogon) Yes Yes

FEATURE SUPPORT ON SMA 100 AND SONICWALL FIREWALLS

NOTE: The features listed above in the Feature Support on SMA 100 and SonicWall Firewalls table are
supported only when using NetExtender with the SMA 100 Series.
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Configuring NetExtender
This section explains how to configure SonicWall NetExtender.

Topics:

l User Prerequisites
l User Configuration Tasks

User Prerequisites
This section describes the user Prerequisites for Windows clients and Linux clients for installing NetExtender.

For Windows Clients
Windows clients must meet the following prerequisites to use NetExtender:

Platform Windows 11/10

Browsers Mozilla Firefox 103.0 and higher

Google Chrome 104.0 and higher

To initially install the NetExtender client, the user must be logged into the PC with administrative privileges.

If the SMA gateway uses a self-signed SSL certificate for HTTPS authentication, it is necessary to install the
certificate before establishing a NetExtender connection. If you are unsure if the certificate is self-signed or
generated by a trusted root Certificate Authority, SonicWall recommends that you import the certificate. The
easiest way to import the certificate is to click Import Certificate on the Virtual Office home page.

When using the network logon method from the Windows login screen, NetExtender uses System Store for
certificate-based authentication. When the user is already logged in to Windows, NetExtender uses the User
Store for certificate-based authentication. A user who wants to use the network logon method when certificate
authentication is also enabled should import his user certificate into the System Store as well as into the User
Store.
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For Linux Clients
Linux 32-bit or 64-bit clients are supported for NetExtender when running one of the following distributions (32-bit
or 64-bit):

l Linux Fedora Core 36 or higher, Ubuntu 20.04 or higher, or OpenSUSE 10.3 or higher, Red Hat Enterprise
Linux 8.x and higher, and CentOS 8.x and higher

The NetExtender client has been known to work on other distributions as well, but these are not officially
supported.

NOTE: Open source Java Virtual Machines (VMs) are not currently supported. If you do not have Java 1.5 or
higher, you can use the command-line interface version of NetExtender.

User Configuration Tasks
SonicWall NetExtender is a software application that enables remote users to securely connect to the remote
network. With NetExtender, remote users can virtually join the remote network. Users can mount network drives,
upload and download files, and access resources in the same way as if they were on the local network.

The following sections describe how to use NetExtender on the various supported platforms:

Windows Platform Installation Installing NetExtender on Windows

Enabling Network Logon (PreLogon) feature on NetExtender

Windows Platform Usage Launching NetExtender Directly from Computer

Installing NetExtender with Microsoft Installer

Configuring NetExtender Properties Configuring Connection Profiles Settings

Configuring Settings

Connection Scripts Settings

Configuring Proxy Settings

Configuring Log Settings

Configuring Acceleration Settings

Configuring Packet Capture Settings

Configuring Languages Settings

Configuring Protocol

Linux Platform Installing NetExtender on Linux

Using NetExtender on Linux
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Installing NetExtender on Windows
The procedure for installing NetExtender is same for all supported browsers on Windows platform.

To install and launch NetExtender for the first time:

1. Log in to the Workplace portal.

2. Click NetExtender.

The prompt is displayed asking you to download the SMA Connect Agent.

3. Download and install the SMA Connect Agent and allow SMA Connect agent to launch NetExtender from
your browser.

NOTE: If the SMA Connect Agent is already installed, click Installed to ensure that you don’t see the
prompt again or click Continue to skip the prompt.

The NetExtender is downloaded automatically and the NetExtender installer launches.
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4. In the User Account Control prompt, click Yes to run the NetExtender installer.
NetExtender is connected.

NOTE: If you see error connecting to NetExtender, click Reconnect, and skip to enter the user
credentials step.

5. Optionally, if you do not see the prompt, the NexExtender client has not downloaded automatically.
Continue executing the next steps to download and install the NetExtender manually.

a. Click the User icon at the upper-right corner of the page.

b. Click Downloads.

c. Select your platform for manual download and click Save File.
The file is saved in your Downloads folder.

6. Navigate to your Downloads folder and double-click NXSetupU.exe to run the installer.
The User Account Control message Do you want to allow the following program to make changes
to this computer? is displays.

7. Click Yes.
The SonicWall NetExtender Setup wizard is launched. TheWelcome screen recommends that you close
all other applications before starting the setup to avoid the need to restart your computer after the
installation. When ready to proceed, click Next.

8. In the License Agreement screen, read the agreement, select I accept the terms of the License
Agreement and then click Next.

9. Optionally you can change the Destination Folder field click Browse and click Next.

10. Select or clear the shortcut options checkboxes that you require. The following options are selected by
default:

l Create a shortcut on StartMenu.

l Create a shortcut on QuickLaunch bar.

l Create a shortcut on Desktop.

11. Click Install.

12. If aWindows Security dialog box displaysWould you like to install this device software?, click
Install.

13. Optionally, you can select the Run SonicWall NetExtender check boxto launch NetExtender
immediately after installation.
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14. Click Finish.

15. After launching NetExtender, type the IP address or FQDN of the SMA appliance in the Server field.
TIP: This is the same server that you point your browser to when accessing the portal page to
download NetExtender.

16. Enter the Username and Password.

17. In the Domain field, type in the domain.
NOTE: This is the same domain shown in the Domain field of the login page when you access the
portal in your browser.

18. Click Connect
NetExtender takes a few seconds to connect to the server and verify your credentials. The NetExtender
status window displays, indicating that NetExtender successfully connected. The NetExtender icon is
displayed in the task bar.
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Field Description

Server Indicates the name of the server to which the NetExtender client is
connected.

Client IP Indicates the IP address assigned to the NetExtender client.

Sent Indicates the amount of traffic the NetExtender client has transmitted since
initial connection.

Received Indicates the amount of traffic the NetExtender client has received since
initial connection.

Throughput Indicates the current NetExtender throughput rate.

19. (Optional) To disconnect NetExtender, click Disconnect.
TIP: Closing the window (clicking the x icon in the upper right corner of the window) does not close
the NetExtender session, but minimizes it to the system tray for continued operation.

Enabling Network Logon (PreLogon) feature on
NetExtender
Perquisites:

l NetExtender must be installed and enabled for Network Logon.
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The Network Logon feature is a default enabled feature. This Network Logon feature will be enabled by default
during NetExtender (NXsetupU.exe) and (MSI installer) installation.

NOTE: The Network Logon is a default, so if you update NetExtender from auto-update or upgraded, the
Network Logon will be installed by default.

Launching VPN Connection using Network Logon
This section provides information on connecting to the VPN tunnel using Network Logon before log on to
Windows accounts.

To launch a VPN connection using Network Logon:

1. Select the Network sign-in icon.

2. VPN is not connected user interface displays, click the Arrow icon.
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3. NetExtender user interface pop-up displays. Enter the details such as Server, Username, Password,
and Domain.

4. Click Connect to establish the VPN connection. Once it is successfully connected, VPN is connected
user interface displays.
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5. Click Back and proceeds with your windows credentials to login Windows user session.

6. If you want to disconnect your VPN at this stage, Click the disconnect icon to disconnect the VPN.

NOTE: Network logon feature does not support EPC, NetExtender Upgrade, and SAML
Authentication but once the Windows user logs in, VPN session is restarted with existing session and
invokes all the functionality that was skipped earlier. Then NetExtender is re-established as per the
new policy.
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To disable Network Logon (Pre-Logon):

1. After the user logs on to Windows user session, Right-click on the NetExtender user interface pop-up
display.

2. Uncheck the Pre-Logon option to disable the Network logon feature.

Launching NetExtender Directly from Computer
After the first access and installation of NetExtender, you can launch NetExtender directly from your computer
without first navigating to the Secure Mobile Access portal.

To launch NetExtender:

1. Navigate to Start > All Programs.

2. Select the SonicWall NetExtender folder, and then click SonicWall NetExtender.
The NetExtender login window is displayed.

3. To display a list of recent SMA servers you have connected to, click the arrow.

4. Enter your username and password.

5. The last domain you connected to is displayed in the Domain field.
NOTE: The NetExtender client reports an error message if the provided domain is invalid when you
attempt to connect. Note that the domain names are case-sensitive.

20SMA 10.2 NetExtender Feature Guide
Configuring NetExtender



6. The drop-down menu at the bottom of the window provides three options for remembering your username
and password:

l Save user name only if server allows

l Save user name and password if server allows

l Always ask for user name & password

TIP: Having NetExtender save your user name and password can be a security risk and should not be
enabled if there is a chance that other people could use your computer to access sensitive information
on the network.

Installing NetExtender with Microsoft Installer
Installing NetExtender through Microsoft Installer (MSI) supports the use of default profile settings during the
installation process where the default server and default domain can be pre-filled along with additional options
that control whether the server and domain fields can be edited by a standard user. This feature is designed
specifically for administrators who want their default servers and domains pre-set during the installation process.

To set the default server and domain during the NetExtender Installation with Microsoft Installer:

1. On the Default Profile Setting page, enter the IP address of the Default Server and the location of the
domain in Default Domain.

2. Disable Allow connections to other profiles to prevent users from connecting to other profiles.
This setting disables the Server and Domain fields for editing on the login page of NetExtender.
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Configuring NetExtender Properties
NetExtender Properties feature helps you to manage the options including settings, log, languages, and so on.

Topics:

l Configuring Connection Profile Settings
l Configuring Settings
l Connection Scripts Settings
l Configuring Proxy Settings
l Configuring Log Settings
l Configuring Acceleration Settings
l Configuring Packet Capture Settings
l Configuring Languages Settings
l Configuring Protocol

Configuring Connection Profile Settings
The Connection Profiles tab displays the Secure Mobile Access connection profiles you have used, including
the IP address of the SMA server, the domain, and the username.
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To manage the connection profiles settings:

1. Click to view the NetExtender Properties window and then click Connection Profiles.

2. Click Create Shortcut to create a shortcut on your desktop that launches NetExtender with the specified
profile.

3. Click Remove to delete a profile.
Or
Click Remove All to delete all the connection profiles.

4. Click Apply to save your changes.

Configuring Settings
The Settings tab allows you to customize the behavior of NetExtender.
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To manage the settings option:

1. Click to view the NetExtender Properties window and then click Settings.
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2. Enable the required settings.

Setting Description

Automatically
connect with profile

NetExtender connects to a specific profile when starting up the computer device.

Automatically start
NetExtender UI

NetExtender launches when you log in to your computer device.

Display NetExtender
UI

Displays NetExtender login window

Minimize to the tray
icon when
NetExtender window
is closed

Enable the NetExtender icon display in the system tray.
NOTE: If this option is not selected, you can only access the NetExtender UI
throughWindow’s programmenu.

Minimize to the tray
icon when
NetExtender
connected

NetExtender icon display in the system tray when you are connected.

Display
Connect/Disconnect
Tips from the
System Tray

NetExtender display tips when you hover the mouse pointer over the NetExtender
icon.

Automatically
reconnect when the
connection is
terminated

NetExtender attempts to reconnect when it loses connection.

Automatically
reconnect when
computer resumed

NetExtender reconnects when the computer resumes from a sleep or a locked
mode.

Display precise
number in
connection status

Displays precise byte value information in the connection status.

Enable UI
animations

Enables the sliding animation effects in the UI.

Disable auto
upgrade when admin
allowed

Eanbles auto upgrades

Uninstall
NetExtender
automatically

NetExtender uninstalls every time you end a session

Disconnect an active
connection

NetExtender logs out of all of your SSL VPN sessions when you exit a
NetExtender session.
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Setting Description

Uninstall EPC Agent
automatically

End Point Control Agent gets uninstalled when NetExtender is uninstalled from
the system.

3. ClickOK to save your changes.

Connection Scripts Settings
Secure Mobile Access provides users with the ability to run batch file scripts when NetExtender connects and
disconnects. The scripts can be used to map or disconnect network drives and printers, launch applications, or
open files or websites.

To manage the connection scripts options:

1. Click to view the NetExtender Properties window and then click Connection Scripts.
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2. Enable the required settings.

Settings Description

Attempt to execute
domain logon script

Enabling this setting, allows the NetExtender to contact the domain controller and
execute the login script.

NOTE: Enabling this feature might cause connection delays while remote
client’s printers and drives are mapped. Make sure the domain controller and
any machines in the logon script are accessible through NetExtender routes.

Hide the console
window

Enable to close the DOS console window while the script runs.

Automatically
execute the batch
file
“NxConnect.bat”

Enabling this setting, runs the script when NetExtender connects.

Automatically
execute the batch
file
“NxDisconnect.bat.

Enabling this setting, runs the script when NetExtender disconnects.

3. ClickOK to save your changes.

Configuring Proxy Settings
Secure Mobile Access supports NetExtender sessions using proxy configurations. Currently, only HTTPS proxy
is supported. When launching NetExtender from the Web portal, if your browser is already configured for proxy
access, NetExtender automatically inherits the proxy settings.
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To manage the proxy settings options:

1. Click to view the NetExtender Properties window and then click Proxy.

2. Select Enable proxy settings.

3. Select the required settings.

Setting Description

Automatically detect
settings

To use this setting, the proxy server must support Web Proxy Auto
Discovery Protocol (WPAD)) that can push the proxy settings script to the
client automatically.

Use automatic
configuration script

If you know the location of the proxy settings script, select this option and
enter the URL of the scrip in the Address field.

Use proxy server Select this option to enter the Address and Port of the proxy server.

BypassProxy Enter an IP address or domain in the BypassProxy field to allow direct
connections to those addresses that bypass the proxy server. If required,
enter User name and Password for the proxy server.

NOTE: If you have not entered the User name and Password, then
Properties window is displayed, and you might need to enter the User
name and Password when you connect for first time.

4. Click Apply to save your changes.
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Configuring Log Settings
The Log tab provides the basic control over the NetExtender Log and Debug Log.

To manage the Log options:

1. Click to view the NetExtender Properties window and then click Log.

2. Select the required settings.

Settings Description

Unlimited log file size Enable to establish the size of the NetExtender Log

Set maximum log file size to To set a maximum size, use the adjoining arrows.

Clear NetExtender Log To clear the NetExtender Log

Clear Debug Log To clear the debug log.
NOTE: Select Enable NetExtender Log to enable Clear
Debug Log.

Log Viewer To view the current NetExtender log.

3. ClickOK to save the changes.

Configuring Acceleration Settings
The Acceleration Settings tab allows you to accelerate IP and port to ensure high performance.
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NOTE: Acceleration is supported only on Gen6.

To manage the Acceleration settings:

1. Click to view the NetExtender Properties window and then click Acceleration.

2. Select Enable Acceleration to enable the IP Address acceleration and enter the IP address. You can
include or exclude the IP Address as required.

3. Specify the Port number and select Check for upgrades automatically to enable upgrades. You can
include or exclude the Ports as required.

4. Optionally, you can select the Enable WXAC Debug log checkbox, if required.

5. ClickOK to save your changes.

Configuring Packet Capture Settings
The Packet Capture tab allows you to enable and disable packet capture and data compression on
NetExtender. You must have Administrator privileges to change packet capture settings.
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To manage the Packet Capture settings:

1. Click to view the NetExtender Properties window and then click Packet Capture.

2. To enable packet capture, select Enable NetExtender packet capture.

3. Select Clear the capture when NetExtender exits to clear all captured packet data when NetExtender
exits.

4. Select Enable capture cache to clear all captured packet data when NetExtender exits.

5. Select Enable data compression to enable data compression of captured packets.

6. Select Attempt to disable data compression during packet capture.if packet capture is enabled when
NetExtender connects and you want to disable data compression immediately.

7. ClickOK to save the changes.

Configuring Languages Settings
The Languages tab allows you to define your language settings and import other packs on NetExtender.
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To manage the Language settings:

1. Click to view the NetExtender Properties window and then click Advanced.

2. The Language drop-down list allows you to select the available languages on NetExtender.
NOTE: The default language is English. After you select a language from the drop-down list, clickOK.

3. Restart NetExtender for the new language to be applied.

4. Click Import to upload a new language pack to NetExtender.
The languages packs must be in the .ZIP format. Select the language pack you want to import.

5. ClickOpen.
After the import, the language displays in the Language drop-down list.

6. ClickOK to save your changes.

Configuring Protocol
Within the NetExtender Properties dialog box, click the Protocol heading in the menu on the left panel. The
available options allow you to select your protocol on NetExtender.
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To configure Protocol:

1. You can select from the following three protocol options:

l Automatic: Connects to the tunnel that you have selected as your first preference on the
management interface.

l WireGuard: Connects to WireGuard tunnel. If WireGuard is not enabled, or fail to connect, it will
return back to login page.

l SSLVPN: Connects to SSLVPN tunnel.

2. ClickOK.

Installing NetExtender on Linux
Secure Mobile Access supports NetExtender on Linux. To use NetExtender on your Linux system, your system
must meet the following prerequisites:

l i386-compatible distribution of Linux

l Linux Fedora Core 36 or later, Ubuntu 20.04 or later, or OpenSUSE 10.3 or later, Red Hat Enterprise
Linux 8.x and later, and CentOS8.x and later

To install NetExtender on your Linux system:

1. Log in to the Workplace portal.

2. Click NetExtender.
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A pop-up window indicates that you have chosen to open a .tgz file.

3. ClickOK to save it to your default download directory.

NOTE: You must be logged in as root to install NetExtender, although many Linux systems allows the
sudo ./install command to be used if you are not logged in as root.

4. To install NetExtender from the CLI, navigate to the directory where you saved the .tgz file and enter the
tar -zxf NetExtender.tgz command.

5. Enter the cd netExtenderClient/ command.

6. Enter su -C “ ./install" to install NetExtender.

7. Enter your system password.
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8. The installer asks if you want non-root users to be able to run NetExtender. Enter either y for yes or n for
no.

NOTE: To allow non-root users to run NetExtender, the installer sets PPPD to run as root. This could
be considered a security risk.

Using NetExtender on Linux
To use NetExtender on a Linux computer:

1. After NetExtender is installed, there are two methods to launch it:

l Click the NetExtender icon in the Applications menu, under either the Internet or Network
category.

l Enter the netExtenderGui command.

2. The first time you connect, you must enter the SMA server name in the Server field.

3. Enter your username and password.

4. The first time you connect, you must enter the Domain name.
NOTE: The domain name is case-sensitive. NetExtender remembers the domain name in the future.

5. To view the NetExtender routes, select the Routes tab in the main NetExtender window.
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6. To view the NetExtender DNS server information, select the DNS tab in the main NetExtender window.
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Using NetExtender
This chapter describes how to use NetExtender on the various supported platforms:

l Viewing the NetExtender Log

l Disconnecting NetExtender

l Upgrading NetExtender

l Changing Passwords

l Authentication Methods

l Uninstalling NetExtender

l Verifying NetExtender operation from the System Tray

l Using the NetExtender Command Line Interface

Viewing the NetExtender Log
The NetExtender log displays information on NetExtender session events. The log file name is saved as
NetExtender.dbg stored in C:\Program Files\SonicWall\SSLVPN\NetExtender.

1. To view the NetExtender log, log in to the NetExtender and click .

2. To view details of a log message, double-click a log entry,
Or
Go to View > Log Detail to open the log detail pane.

3. To save the log, click the Export icon.
Or
Go to Log > Export.

4. To filter the log to display entries from a specific duration of time, go to the Filter menu and select the cutoff
threshold.

5. To filter the log by type of entry, go to Filter > Level and select one of the level categories.

3
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The available options are Fatal, Error,Warning, and Info, in descending order of severity. The log
displays all entries that match or exceed the severity level. For example, when selecting the Error level,
the log displays all Error and Fatal entries, but notWarning or Info entries.

NOTE: It could take several minutes for the Debug Log to load. During this time, the Log window is
not accessible, although you can open a new Log window while the Debug Log is loading.

6. To clear the log, click Log > Clear Log.

Disconnecting NetExtender
To disconnect NetExtender:

1. Right click the NetExtender icon in the system tray to display the NetExtender icon menu and click
Disconnect.
Or
You can also disconnect by double-clicking on the NetExtender icon to open the NetExtender window and
then click Disconnect.
The NetExtender session disconnects after few seconds.
When NetExtender is disconnected, the NetExtender window displays and gives you the option to either
Reconnect or Close NetExtender.

Upgrading NetExtender
NetExtender automatically notifies users when an updated version of NetExtender is available. Users are
prompted to clickOK and NetExtender downloads and installs the update from the SMA security appliance.

Changing Passwords
Before connecting to the new version of NetExtender, users might be required to reset their password by suppling
their old password, along with providing and re-verifying a new one.

Authentication Methods
NetExtender supports various two factor authentication methods, including one-time password, RSA, and Vasco,
and authentications in mobile applications using Google, Microsoft, and Duo. If an Administrator has configured
one-time passwords to be required to connect through NetExtender, you are asked to provide this information
before connecting.
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If an Administrator has configured RSA pin-mode authentication to be required to connect through NetExtender,
users are asked whether they want to create their own pin, or receive one that is system-generated.

After the pin has been accepted, you must wait for the token to change before logging in to NetExtender with the
new passcode.

During authentication, the SMA server can be configured by the Administrator to request a client certificate. In this
case, users must select a client certificate to use when connecting.

Uninstalling NetExtender
The NetExtender utility is automatically installed on your computer. To remove NetExtender, click Start > All
Programs, click SonicWall NetExtender, and then click Uninstall.

You can also configure NetExtender to automatically uninstall when your session is disconnected.

To configure NetExtender to automatically uninstall when your session is disconnected:

1. Right click the NetExtender icon in the system tray and click Properties window is displayed.

2. Click the Settings tab.

3. Select Uninstall NetExtender automatically to have NetExtender uninstall every time you end a
session.

4. Click Apply.
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Verifying NetExtender operation from the
System Tray
To view options in the NetExtender system tray, right-click the NetExtender icon in the system tray. The following
are some tasks you can complete with the system tray.

l Displaying Route Information: To display the routes that NetExtender has installed on your system,
click the Route Information option in the system tray menu. The system tray menu displays the default
route and the associated subnet mask.

l Displaying Connection Information: You can display connection information by mousing over the
NetExtender icon in the system tray.

Using the NetExtender Command Line
Interface

NOTE: The NetExtender command line interface is only available on Windows platforms.

To launch the NetExtender CLI:

1. Launch the Windows Command Prompt by going to the Start > Run, enter cmd, and click OK.

2. Change directory to where NetExtender is installed. Type cd Program Files\SonicWall\SSL-

VPN\NetExtender.
NOTE: The specific command directory could be different on your computer. UseWindows Explorer
to find the directory path where NetExtender is located.

Command Option Description

NECLI addprofile Creates a NetExtender profile

-s server The IP address or hostname of the SMA server

-u user-name The username for the account.

-p password The password for the account.

-d domain-name The domain to connect to.

NECLI connect Initiates a NetExtender session.

-s server The IP address or hostname of the SMA server.

-u user-name The username for the account.

-p password The password for the account.

-d domain-name The domain to connect to.

NETEXTENDER CLI COMMANDS AND OPTIONS
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Command Option Description

- clientcertificatethumb thumb The SSL Client Certificate thumbprint value.

- clientcertificatename name The SSL Client Certificate name.

NECLI deleteprofile Deletes a saved NetExtender profile.

-s server The IP address or hostname of the SMA server.

-u user-name The username for the account.

-d domain-name The domain to connect to.

NECLI disconnect Disconnects

timeout (Optional) Timeout duration, after which the
session is disconnected.

NECLI displayprofile Displays all NetExtender profiles.

-s server (Optional) Displays only the profiles that are
saved for the specified server

-u user-name (Optional) Displays only the profiles that are
saved for the specified user name.

-d domain-name (Optional) Displays only the profiles that are
saved for the specified domain name.

NECLI queryproxy Checks the connect to the proxy server.

NECLI reconnect Attempts to reconnect to the server.

NECLI showstatus Displays the status of the current NetExtender
session.

NECLI setproxy Configures proxy settings for NetExtender

-t [0 |1 | 2 | 3] There are three options for setting proxy settings:
0 - Disable proxy.
1 - Automatically detects proxy settings. The
proxy server must support Web Proxy Auto
Discovery Protocol (WPAD).
2 - Uses a proxy configuration script.
3 - Manually configure the proxy server

-s proxy address The address of the proxy script or proxy server

-o port The port number.

-u user name The user name for the proxy server.

-p password The password name for the proxy server.

-b bypass-proxy Bypasses the previously configured proxy
settings.

-save Saves the proxy settings.

NECLI viewlog Displays the NetExtender log.
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NetExtender Troubleshooting
This chapter provides you help with troubleshooting information for the SonicWall NetExtender utility.

NETEXTENDER CANNOT BE INSTALLED

l Problem: NetExtender cannot be installed.

l Solution:

1. Check your OS Version, NetExtender only supports Linux OpenSUSE, CentOS, Red Hat
Enterprise in addition to Fedora Core and Ubuntu. An i386-compatible Linux distribution is
required, along with Sun Java 1.6.0_10+.

2. Check that the user has administrator privilege, NetExtender can only install/work under the user
account with administrator privileges.

3. Check if ActiveX has been blocked by Internet Explorer or third-party blockers.

4. If the problem still exists, obtain the following information and send to support:

l The version of Secure Mobile Access NetExtender Adapter from Device Manager.

l The log file located at C:\Program files\SonicWall\SMA\NetExtender.dbg.

l The event logs in the Event Viewer found under theWindows> Control Panel
>Administrator Tools folder. Select Applications and System events and use the Action
/Save Log Filemenu to save the events in a log file.

NETEXTENDER CONNECTION ENTRY CANNOT BE CREATED

l Problem: NetExtender connection entry cannot be created.

l Solution:

1. Navigate to Device Manager and check if the Secure Mobile Access NetExtender Adapter has
been installed successfully. If not, delete the adapter from the device list, reboot the machine and
install NetExtender again.

2. Navigate to Windows Service manager under Control Panel > Administrator Tools > Services.
Look for the Remote Access Auto Connection Manager and Remote Access Connection
Manager to see if those two services have been started. If not, set them to automatic start, reboot
the machine, and install NetExtender again.

3. Check if there is another dial-up connection in use. If so, disconnect the connection, reboot the
machine and install NetExtender again.

4
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4. If problem still exists, obtain the following information and send them to support:

l The version of Secure Mobile Access NetExtender Adapter from Device Manager.

l The log file located at C:\Program files\SonicWall\SMA\NetExtender.dbg.

l The event logs in Control Panel > Administrator Tools > Event Viewer. Select
Applications and System events and use the Action /Save Log Filemenu to save the
events in a log file.

NETEXTENDER CANNOT CONNECT

l Problem: NetExtender cannot connect.

l Solution:

1. Navigate to Device Manager and check if the Secure Mobile Access NetExtender Adapter has
been installed successfully. If not, delete the adapter from the device list, reboot the machine and
install NetExtender again.

2. Navigate to Network connections to check if the Secure Mobile Access NetExtender Dialup entry
has been created. If not, reboot the machine and install NetExtender again.

3. Check if there is another dial-up connection in use, if so, disconnect the connection and reboot the
machine and connect NetExtender again.

4. If problem still exists, obtain the following information and send them to support:

l The version of Secure Mobile Access NetExtender Adapter from Device Manager.

l The log file located at C:\Program files\SonicWall\SMA\NetExtender.dbg.

l The event logs in Control Panel > Administrator Tools > Event Viewer. Select
Applications and System events and use the Action /Save Log Filemenu to save the
events in a log file.

NETEXTENDER BSOD AFTER CONNECTED

l Problem: NetExtender BSOD after connected

l Solution:

1. Uninstall NetExtender, reboot machine, reinstall the latest version NetExtender.

2. Obtain the following information and send them to support:

l The version of Secure Mobile Access NetExtender Adapter from Device Manager.

l The log file located at C:\Program files\SonicWall\SMA\NetExtender.dbg.

l Windows memory dump file located at C:\Windows\MEMORY.DMP. If you cannot find this
file, then open System Properties click Startup and Recovery Settings under the
Advanced tab.

l Select Complete Memory Dump, Kernel Memory Dump or Small Memory Dump in the
Write Debugging Information drop-down list. You should also reproduce the BSOD to get
the dump file.
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l The event logs in Control Panel > Administrator Tools > Event Viewer. Select
Applications and System Events and use the Action /Save Log Filemenu to save the
events in a log file.

Related Topics:
l https://www.sonicwall.com/support/search-results/?searchtext=netextender+config

l https://www.sonicwall.com/support/knowledge-base/dns-ip-not-getting-updated-on-netextender-after-
changing-the-dns-on-the-box/180619133203645/

l https://www.sonicwall.com/support/knowledge-base/enable-proxy-settings-in-the-
netextender/170505506096633/

l https://www.sonicwall.com/support/knowledge-base/sonicwall-net-extender-service-is-grayed-out-with-9-
0-x-msi-file/190314150454875/

l https://www.sonicwall.com/support/knowledge-base/damaged-version-of-net-extender-error-message-
on-windows-10/170707194358278/

l https://www.sonicwall.com/support/knowledge-base/unable-to-log-in-with-netextender-while-using-
german-special-characters/170502534932980/
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SonicWall Support
Technical support is available to customers who have purchased SonicWall products with a valid maintenance
contract.

The Support Portal provides self-help tools you can use to solve problems quickly and independently, 24 hours a
day, 365 days a year. To access the Support Portal, go to https://www.sonicwall.com/support.

The Support Portal enables you to:

l View knowledge base articles and technical documentation

l View and participate in the Community forum discussions at
https://community.sonicwall.com/technology-and-support.

l View video tutorials

l Access https://mysonicwall.com

l Learn about SonicWall Professional Services

l Review SonicWall Support services and warranty information

l Register for training and certification

l Request technical support or customer service

To contact SonicWall Support, visit https://www.sonicwall.com/support/contact-support.
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End User Product Agreement
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Open Source Code
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